您的位置:首页 > 其它

HDU 1568 Fibonacci (取对数)

2018-03-17 15:38 453 查看
Fibonacci

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5887 Accepted Submission(s): 2793

Problem Description

2007年到来了。经过2006年一年的修炼,数学神童zouyu终于把0到100000000的Fibonacci数列

(f[0]=0,f[1]=1;f[i] = f[i-1]+f=2”>i-2)的值全部给背了下来。

接下来,CodeStar决定要考考他,于是每问他一个数字,他就要把答案说出来,不过有的数字太长了。所以规定超过4位的只要说出前4位就可以了,可是CodeStar自己又记不住。于是他决定编写一个程序来测验zouyu说的是否正确。

Input

输入若干数字n(0 <= n <= 100000000),每个数字一行。读到文件尾。

Output

输出f
的前4个数字(若不足4个数字,就全部输出)。

Sample Input

0

1

2

3

4

5

35

36

37

38

39

40

Sample Output

0

1

1

2

3

5

9227

1493

2415

3908

6324

1023

思路

对于任意一个数可以写成这样的形式

d.xxx⋯∗10k−1d.xxx⋯∗10k−1

对这个数取对数即得到

log10(d.xxx⋯)+log10(10k−1)log10(d.xxx⋯)+log10(10k−1)

=k−1+log10(d.xxx⋯)=k−1+log10(d.xxx⋯)

log10(d.xxx⋯)log10(d.xxx⋯)为一个(0,1)(0,1)的数字,那么

d.xxx⋯=10log10(d.xxx⋯)d.xxx⋯=10log10(d.xxx⋯)

然后我们再回来讲这道题,他是要求得斐波那契数列的前4项

我们知道斐波那契数列的通项公式

an=15–√((1+5–√2)n−(1−5–√2)n)an=15((1+52)n−(1−52)n)

不知道的话也可以用特征方程求解,anan的公式还可以转换一下变成

an=15–√(1+5–√2)n(1−(1−5–√1+5–√)n)an=15(1+52)n(1−(1−51+5)n)

(1−5√1+5√)n(1−51+5)n在n大于20的时候就已经非常接近0了,所以这一项可以省去

所以an=15–√(1+5–√2)nan=15(1+52)n

对其去对数即

log10(an)=log10(15–√)+nlog10(1+5–√2)log10(an)=log10(15)+nlog10(1+52)

然后我们就可以利用我们一开始介绍的方法来求解d.xxx⋯d.xxx⋯

令x=log10(an)x=log10(an),那么log10(d.xxx⋯)=x−floor(x)log10(d.xxx⋯)=x−floor(x)

d.xxx⋯=10x−floor(x)d.xxx⋯=10x−floor(x),那么前4位就把他乘以1000即可

#include <iostream>
#include <fstream>
#include <algorithm>
#include <cstring>
#include <math.h>
using namespace std;
int main()
{
int f[21];
f[0]=0;
f[1]=1;
for(int i=2;i<21;i++)
f[i]=f[i-1]+f[i-2];
int n;
while(scanf("%d",&n)!=EOF)
{
if(n<=20)
printf("%d\n",f
);
else
{
double x=log10(1/sqrt(5))+n*1.0*log10((1.0+sqrt(5))*0.5);
x=x-floor(x);
x=pow(10,x);
x=x*1000;
printf("%d\n",(int)x);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: