您的位置:首页 > 其它

【HDU 2824 The Euler function】+ 欧拉函数

2017-03-11 21:08 429 查看
The Euler function

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 6488 Accepted Submission(s): 2736

Problem Description

The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+….+ (b)

Input

There are several test cases. Each line has two integers a, b (2< a < b < 3000000).

Output

Output the result of (a)+ (a+1)+….+ (b)

Sample Input

3 100

Sample Output

3042

Source

2009 Multi-University Training Contest 1 - Host by TJU

题意 : (a) 1 ~ a 中与 a 互质的数的个数,求 (a) + (a + 1) + …(b)

思路 : 欧拉函数求质数~

AC代码:

#include<cstdio>
typedef long long LL;
const int K = 3e6 + 10;
int ol[K];
int main()
{
int a,b;
for(int i = 1; i < K; i++) ol[i] = i;
for(int i = 2; i < K; i++)
if(i == ol[i]) // i 为质数
for(int j = i; j < K; j += i)
ol[j] = ol[j] / i * (i - 1); // j 的因子有 i,欧拉函数
while(scanf("%d %d",&a,&b) != EOF){
LL cut = 0; for(int i = a; i <= b; i++) cut += ol[i];
printf("%lld\n",cut);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: