您的位置:首页 > 其它

hdu 2824 The Euler function (欧拉函数)

2014-04-08 09:53 423 查看

The Euler function

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3333 Accepted Submission(s): 1368


[align=left]Problem Description[/align]
The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)

[align=left]Input[/align]
There are several test cases. Each line has two integers a, b (2<a<b<3000000).

[align=left]Output[/align]
Output the result of (a)+ (a+1)+....+ (b)

[align=left]Sample Input[/align]

3 100

[align=left]Sample Output[/align]

3042

[align=left]Source[/align]
2009 Multi-University Training Contest 1 - Host by TJU

[align=left]Recommend[/align]
gaojie | We have carefully selected several similar problems for you: 2818 2825 2817 2822 2820

求欧拉函数,打表题:

//453MS    23700K    484 B    G++
#include<stdio.h>
#define N 3000005
__int64 ans
;
void init()
{
for(int i=1;i<N;i++) ans[i]=i;
for(int i=2;i<N;i+=2) ans[i]/=2;
for(int i=3;i<N;i+=2)
if(ans[i]==i){
for(int j=i;j<N;j+=i) ans[j]=ans[j]/i*(i-1);
}
}
int main(void)
{
int a,b;
init();
while(scanf("%d%d",&a,&b)!=EOF)
{
__int64 ret=0;
for(int i=a;i<=b;i++) ret+=ans[i];
printf("%I64d\n",ret);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: