您的位置:首页 > 其它

hdu-2824 The Euler function(欧拉函数)

2016-03-13 23:32 351 查看
题目链接:

The Euler function

Time Limit: 2000/1000 MS (Java/Others)

Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4987 Accepted Submission(s): 2098


[align=left]Problem Description[/align]
The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)

[align=left]Input[/align]
There are several test cases. Each line has two integers a, b (2<a<b<3000000).

[align=left]Output[/align]
Output the result of (a)+ (a+1)+....+ (b)

[align=left]Sample Input[/align]

3 100

[align=left]Sample Output[/align]

3042
题意:求[a,b]的欧拉函数和;
AC代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
const int N=3e6+3;
int phi
;
int get_phi()
{
for(int i=2;i<N;i++)
{
if(!phi[i])
{
for(int j=i;j<N;j+=i)
{
if(!phi[j])phi[j]=j;
phi[j]=phi[j]/i*(i-1);
}
}
}
}
int main()
{
get_phi();
int a,b;
while(scanf("%d%d",&a,&b)!=EOF)
{
long long ans=0;
for(int i=a;i<=b;i++)
{
ans+=(long long)phi[i];
}
cout<<ans<<"\n";
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: