您的位置:首页 > 其它

HDU 2824(The Euler function)欧拉函数

2018-03-22 21:23 405 查看
The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)
InputThere are several test cases. Each line has two integers a, b (2<a<b<3000000). Output Output the result of (a)+ (a+1)+....+ (b) Sample Input
3 100
Sample Output
3042

题意:输入两个数,求解这个区间欧拉函数值之和数据不大 直接打表输出
#include<bits/stdc++.h>
#define LL long long
#define maxn 3000010
using namespace std;
LL phi[maxn];
int main()
{
ios::sync_with_stdio(false),cin.tie(0),cout.tie(0);
for(int i=2;i<maxn;i++)
{
phi[i]=i;
}
for(int i=2;i<maxn;i++)
{
if(phi[i]==i)
{
for(int j=i;j<maxn;j+=i)
{
phi[j]=phi[j]/i*(i-1);
}
}
}
LL l,r;
while(cin>>l>>r)
{
LL ans=0;
for(int i=l;i<=r;i++)
{
ans+=phi[i];
}
cout<<ans<<endl;
}
return 0;
}
继续加油!
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM