您的位置:首页 > 其它

HDU 2824 The Euler function【欧拉函数 打表】

2015-08-24 19:07 411 查看

The Euler function

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4513 Accepted Submission(s): 1876



[align=left]Problem Description[/align]
The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very
easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)

[align=left]Input[/align]
There are several test cases. Each line has two integers a, b (2<a<b<3000000).

[align=left]Output[/align]
Output the result of (a)+ (a+1)+....+ (b)

[align=left]Sample Input[/align]

3 100


[align=left]Sample Output[/align]

3042


题目大意就是说,求a到b之间的各个数的欧拉函数值之和

wa了几次,改了好几个地方,最后

#include <iostream>
#include<cstdio>
#include<cstring>
#define maxn 3000000
using namespace std;
int store[maxn+100];
void func()
{
memset(store,0,sizeof(store));
for(int i=1;i<maxn;++i)
store[i]=i;
for(int i=2;i<maxn;++i)
{
if(store[i]==i)
{
for(int j=i;j<maxn;j+=i)
store[j]=store[j]/i*(i-1);//发现这里如果是先乘再除就会错(然而我目前并不造为什么)
}
}
}
int main()
{
int a,b;
__int64 sum;
func();
while(~scanf("%d%d",&a,&b))
{
sum=0;
for(int i=a;i<=b;++i)
sum+=store[i];
printf("%I64d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: