您的位置:首页 > 其它

hdu 2824 The Euler function 欧拉函数打表

2016-05-05 23:58 369 查看

The Euler function

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)


[align=left]Problem Description[/align]
The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)

[align=left]Input[/align]
There are several test cases. Each line has two integers a, b (2<a<b<3000000).

[align=left]Output[/align]
Output the result of (a)+ (a+1)+....+ (b)

[align=left]Sample Input[/align]

3 100

[align=left]Sample Output[/align]

3042

[align=left]Source[/align]
2009 Multi-University Training Contest 1 - Host by TJU
思路:欧拉函数打表;

#include<iostream>
#include<cstdio>
#include<cmath>
#include<string>
#include<queue>
#include<algorithm>
#include<stack>
#include<cstring>
#include<vector>
#include<list>
#include<set>
#include<map>
using namespace std;
#define ll __int64
#define mod 1000000007
#define inf 999999999
//#pragma comment(linker, "/STACK:102400000,102400000")
int scan()
{
int res = 0 , ch ;
while( !( ( ch = getchar() ) >= '0' && ch <= '9' ) )
{
if( ch == EOF ) return 1 << 30 ;
}
res = ch - '0' ;
while( ( ch = getchar() ) >= '0' && ch <= '9' )
res = res * 10 + ( ch - '0' ) ;
return res ;
}
int p[3000010],N=3000010;
void phi()
{
for(int i=1; i<N; i++)  p[i] = i;
for(int i=2; i<N; i+=2) p[i] >>= 1;
for(int i=3; i<N; i+=2)
{
if(p[i] == i)
{
for(int j=i; j<N; j+=i)
p[j] = p[j] - p[j] / i;
}
}
}
int main()
{
int x,y,z,i,t;
phi();
while(~scanf("%d%d",&x,&y))
{
ll ans=0;
for(i=x;i<=y;i++)
ans+=p[i];
printf("%I64d\n",ans);
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: