您的位置:首页 > 其它

1121. Damn Single (25)

2018-03-03 14:53 441 查看

1121. Damn Single (25)

时间限制300 ms
内存限制65536 kB
代码长度限制16000 B
判题程序Standard作者CHEN, Yue
"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.Input Specification:Each input file contains one test case. For each case, the first line gives a positive integer N (<=50000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (<=10000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.Output Specification:First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.Sample Input:
3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333
Sample Output:
5
10000 23333 44444 55555 88888

#include<stdio.h>
#include<vector>
#include<algorithm>
using namespace std;
int cp[100010];//是否有对象
int present[100010];//对象是否到场
vector<int>ans;
int main(){
int n,m,i,cp1,cp2;
scanf("%d",&n);
for(i=0;i<100010;i++){
cp[i]=-1;
}
for(i=0;i<n;i++){
scanf("%d %d",&cp1,&cp2);
cp[cp1]=cp2;
cp[cp2]=cp1;
}
scanf("%d",&m);
int query[m];
for(i=0;i<m;i++){
scanf("%d",&query[i]);
present[query[i]]=1;
}
for(i=0;i<m;i++){
if(cp[query[i]]==-1||present[cp[query[i]]]==0){//无对象或者对象不在场
ans.push_back(query[i]);
}
}
sort(ans.begin(),ans.end());
printf("%d\n",ans.size());
for(i=0;i<ans.size();i++){
if(i){
printf(" ");
}
printf("%05d",ans[i]);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: