您的位置:首页 > 其它

PAT (Advanced Level)1121. Damn Single (25)第二个测 4000 试点过不去,求助

2018-03-12 14:26 495 查看

1121. Damn Single (25)

时间限制300 ms
内存限制65536 kB
代码长度限制16000 B
判题程序Standard作者CHEN, Yue
"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.Input Specification:Each input file contains one test case. For each case, the first line gives a positive integer N (<=50000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (<=10000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.Output Specification:First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.Sample Input:
3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333
Sample Output:
5
10000 23333 44444 55555 88888
//1121. Damn Single(25)
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <map>
#include <set>
using namespace std;
set<int>c;
set<int>uncertain;
map<int, int>maps;
int n, m, a,b,peo,sub=0,single[50005];
int main() {
cin >> n;
for (int i = 0; i < n; i++) {
cin >> a >> b;
maps[a] = b;
maps[b] = a;
c.insert(a);
c.insert(b);
}
cin >> m;
while (m--) {
cin >> peo;
auto it = c.find(peo);
if (it == c.end())
single[sub++] = peo;
else uncertain.insert(peo);
}
for (auto it = uncertain.begin(); it != uncertain.end();it++) {
auto ite = uncertain.find(maps[*it]);
if(ite==uncertain.end())
single[sub++] = *it;
}
sort(single, single + sub);
cout << sub << endl;
printf("%05d", single[0]);
for (int i = 1; i < sub;i++) {
printf(" %05d", single[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: