您的位置:首页 > 其它

1121. Damn Single (25)

2017-02-24 22:47 357 查看
"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<=50000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (<=10000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.
Output Specification:
First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.
Sample Input:
3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333
Sample Output:
5
10000 23333 44444 55555 88888
//   除了单身的还有 对象没有没有来的都 add 到数组中进行输出
#include <iostream>
#include <cstdio>
#include <map>
#include <vector>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 100005;
int vis[maxn];
int a[maxn];
int main() {
memset(vis,0,sizeof(vis));
int n,x1,x2,m;
map<int,int> mp;
vector<int> ans;
cin >> n;
for (int i = 0; i < n; i++) {
cin >> x1 >> x2;
mp[x1] = x2;// mp[111111] == 222222
mp[x2] = x1;
}
cin >> m;
for (int i = 0; i < m; i++) {
cin >> a[i];
vis[a[i]] = 1;//111111   vis[222222] == 1
}
for (int i = 0; i < m; i++) {
if (!(vis[a[i]] == 1 && vis[mp[a[i]]] == 1)) {
ans.push_back(a[i]);
}
}
cout << ans.size() << endl;
sort(ans.begin(),ans.end());
for (int i = 0; i < ans.size(); i++) {
printf("%05d%c", ans[i], i==(ans.size()-1)?'\n':' ');
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: