您的位置:首页 > 其它

1121. Damn Single (25)

2017-09-10 21:02 459 查看


1121. Damn Single (25)

时间限制

300 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=50000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After
the list of couples, there is a positive integer M (<=10000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.
Sample Input:
3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333

Sample Output:
5
10000 23333 44444 55555 88888


注意控制格式  %05d 检查了半天。。。

#include<stdio.h>
#include<map>
#include<set>
#include<vector>
using namespace std;
map<int,int>couple;
set<int>temp,ans;
vector<int>name;
int main(){
int n,m,i,p1,p2,query;
scanf("%d",&n);
for(i=0;i<n;i++){
scanf("%d %d",&p1,&p2);
couple[p1]=p2;
couple[p2]=p1;
}
scanf("%d",&m);
for(i=0;i<m;i++){
scanf("%d",&query);
temp.insert(query);
name.push_back(query);
}
int lover;
for(i=0;i<m;i++){
lover=couple[name[i]];
if(lover==0){ //lover为0有两种情况,1.对象就是00000 2.对象不存在
if(couple[0]!=name[i]){ //对应第2种情况
ans.insert(name[i]);continue;
}
}
if(temp.find(lover)==temp.end()){
ans.insert(name[i]);
}
}
printf("%d\n",ans.size());
set<int>::iterator it=ans.begin();
int flag=0;
for(;it!=ans.end();it++){
if(flag==0){
printf("%05d",*it);flag=1;
}
else{
printf(" %05d",*it);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: