您的位置:首页 > 其它

PAT - 甲级 - 1121. Damn Single (25)

2016-12-13 13:18 417 查看
"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=50000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999).
After the list of couples, there is a positive integer M (<=10000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:
3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333

Sample Output:
5
10000 23333 44444 55555 88888


题目大意:点击查看

#include<cstdio>
#include<cstring>
#define N 100000
using namespace std;
int p
,p1
;
int n,m,a,b;
int main(){
memset(p,0,sizeof(p));

scanf("%d",&n);
for(int i=0 ;i<n ;i++){
scanf("%d%d",&a,&b);
p[a]=b; p[b]=a;
}

scanf("%d",&m);
for(int i=0 ;i<m ;i++){
scanf("%d",&p1[i]);
}

for(int i=0 ;i<m ;i++){
if(p[p1[i]]==0){
p[p1[i]]=-1;
}
else if(p[p1[i]]==1){

}
else if(p[p1[i]]==-1){

}
else{
for(int j=i+1 ;j<m ;j++){
if(p[p1[i]]==p1[j]){
p[p1[i]]=1; p[p1[j]]=1;
break;
}
}
if(p[p1[i]]!=1) p[p1[i]]=-1;
}

}

int cnt = 0;
for(int i=0 ;i<N ;i++){
if(p[i]==-1){
cnt++;
}
}

printf("%d\n",cnt);
int flag =1;
for(int i=0 ;i<N ;i++){
if(p[i]==-1){
if(flag){
flag=0;
printf("%05d",i);
}else{
printf(" %05d",i);
}
}

}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: