您的位置:首页 > 其它

1121. Damn Single (25)

2018-01-18 09:02 309 查看
"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.Input Specification:Each input file contains one test case. For each case, the first line gives a positive integer N (<=50000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (<=10000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.Output Specification:First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.
Sample Input:
3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333
Sample Output:
5
10000 23333 44444 55555 88888
#include <iostream>
#include <set>
#include <cstdio>
using namespace std;

int main()
{
int n,m;
int couple[100000],people[5000],isExit[100000]={-1};
set<int> ans;
cin>>n;
for(int i=0;i<n;i++)
{
int a,b;
scanf("%d %d",&a,&b);
couple[a]=b;
couple[b]=a;
}
cin>>m;
for(int i=0;i<m;i++)
{
scanf("%d",&people[i]);
isExit[people[i]]=1;
}
for(int i=0;i<m;i++)
{
if(isExit[couple[people[i]]]!=1)
{
ans.insert(people[i]);
}
}
cout<<ans.size()<<endl;
for(set<int>::iterator it=ans.begin();it!=ans.end();it++)
{
if(it!=ans.begin())
{
cout<<" ";
}
printf("%05d",*it);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: