您的位置:首页 > 其它

【PAT】【Advanced Level】1121. Damn Single (25)

2017-09-13 15:58 281 查看


1121. Damn Single (25)

时间限制

300 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=50000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After
the list of couples, there is a positive integer M (<=10000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.
Sample Input:
3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333

Sample Output:
5
10000 23333 44444 55555 88888


原题链接:

https://www.patest.cn/contests/pat-a-practise/1121

思路:

map映射couple关系

然后用另一个map映射是否到场

CODE:

#include<iostream>
#include<map>
#include<algorithm>
#include<vector>
#include<cstdio>
using namespace std;
map<int,int> cou;
map<int,int> ma;
vector<int> res;
vector<int> gu;
int main()
{
int n;
cin>>n;
for (int i=0;i<n;i++)
{
int a,b;
cin>>a>>b;
cou[a]=b+1;
cou[b]=a+1;
}
int m;
cin>>m;
for (int i=0;i<m;i++)
{
int t;
cin>>t;
gu.push_back(t);
ma[t+1]=1;
}
for (int i=0;i<m;i++)
{
if (cou[gu[i]]==0 || ma[cou[gu[i]]]==0)
res.push_back(gu[i]);
}
sort(res.begin(),res.end());
cout<<res.size()<<endl;
for (int i=0;i<res.size();i++)
{
if (i!=0) printf(" ");
printf("%05d",res[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: