您的位置:首页 > 其它

PAT--1121. Damn Single (25)

2016-12-10 21:09 435 查看
link

Description

“Damn Single (单身狗)” is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=50000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID’s which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (<=10000) followed by M ID’s of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID’s in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:

3

11111 22222

33333 44444

55555 66666

7

55555 44444 10000 88888 22222 11111 23333

Sample Output:

5

10000 23333 44444 55555 88888

题解

Damn Single indicated that there was nothing to say, being careful about the output.

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <vector>
#include <queue>
#include <map>
#include <string>
#include <set>
using namespace std;

const int maxn = 100000 + 10;
int n, m;
int couple[maxn];
bool vis[maxn];

int main()
{
#ifndef ONLINE_JUDGE
freopen("data.in", "r", stdin);
#endif

cin >> n;
for(int i = 0; i < n; ++i){
int id1, id2;
cin >> id1 >> id2;
couple[id1] = id2;
couple[id2] = id1;
}

cin >> m;
for(int i = 0; i < m; ++i){
int id; cin >> id;
vis[id] = 1;
}

vector<int> ans;
for(int i = 0; i < maxn; ++i){
if(vis[i] && !vis[couple[i]]) ans.push_back(i);
}

cout << ans.size() << endl;
for(int i = 0; i < ans.size(); ++i){
if(i) cout << " ";
printf("%05d", ans[i]);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat