您的位置:首页 > 其它

poj 2559 Largest Rectangle in a Histogram

2016-04-17 14:23 225 查看
Largest Rectangle in a Histogram

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 18332Accepted: 5891
Description

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights
2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:



Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned
at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,...,hn,
where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
Sample Input
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output
8
4000

Hint

Huge input, scanf is recommended.
Source

Ulm Local 2003

题解:单调栈

#include<iostream>
#include<cstdio>
#include<algorithm>
#define ll long long
using namespace std;
ll m,n,a[200003],top,st[200003];
struct data
{
ll l,r;
};data f[200003];
void insert(ll x)
{
while(a[x]<=a[st[top]]&&top)
{
f[x].l=f[st[top]].l;
f[st[top-1]].r=f[st[top]].r;
top--;
}
f[st[top]].r=f[x].r;
st[++top]=x;
}

int main()
{
while (scanf("%lld",&n))
{
if (n==0) break;
for (ll i=1;i<=n;i++)
{
scanf("%lld",&a[i]);
f[i].l=f[i].r=i;
}
for (ll i=1;i<=n;i++)
insert(i);
while(top)
f[st[top-1]].r=f[st[top]].r,top--;
ll ans=0;
for (ll i=1;i<=n;i++)
ans=max(ans,(f[i].r-f[i].l+1)*a[i]);
printf("%lld\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: