您的位置:首页 > 产品设计 > UI/UE

[Data Structure] Maximum Subsequence Sum

2016-04-17 14:19 501 查看
Given a sequence of KK integers
{ N_1N​1​​, N_2N​2​​,
..., N_KN​K​​ }.
A continuous subsequence is defined to be { N_iN​i​​, N_{i+1}N​i+1​​,
..., N_jN​j​​ }
where 1 \le i \le j \le K1≤i≤j≤K.
The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.


Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer KK (\le
10000≤10000).
The second line contains KKnumbers,
separated by a space.


Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence
is not unique, output the one with the smallest indices ii and jj (as
shown by the sample case). If all the KKnumbers
are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.


Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21


Sample Output:

10 1 4


#include <stdio.h>

int main()

{  
int k ;
//input the number the sequence has
while ( scanf("%d",&k) != -1 )
{
int a[k];
//input the sequence
for (int i = 0; i < k; i ++)
{ scanf("%d",&a[i]);
}
int tempSum = 0, tempi = 0, tempj, totalSum = 0, start = 0, end = k - 1;
/*
traverse the sequence, use 'tempSum' acculmulate each num, at first, if tempSum >= 0, 
put current num in the tempSum, then if tempSum > Sum, update the Sum, and shift the tempj
to this index, else just shift the tempi and tempj to this index.
*/
for (int i = 0; i < k; i ++)
{ if ( tempSum >= 0 )
{ tempSum += a[i];
tempj = i;
}
else 
{ tempSum = a[i];
tempi = i;
tempj = i;
}
if ( tempSum > totalSum || ( tempSum == 0 and end == k - 1)/*when the sequence is consist of zero and negative*/)
{
totalSum = tempSum ;
start = tempi;
end = tempj;
}
}
printf("%d %d %d",totalSum,a[start], a[end]);
}

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息