您的位置:首页 > 其它

HDU 1050(其实应该是线段树但规模太小,没必要)

2016-04-17 14:19 232 查看
Moving Tables

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 28118 Accepted Submission(s): 9198

Problem Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3

4

10 20

30 40

50 60

70 80

2

1 3

2 200

3

10 100

20 80

30 50

Sample Output

10

20

30

题目大意:

就是搬桌子,所使用的楼道不能重叠,如果重叠了,只能等这个桌子搬完了才能接着搬,如果不重叠,可以同时搬,问最短时间。

分析:

乍一看像是贪心的去见问题,但实际想想,其实最短时间是由这200节楼道中用的次数最多的那段决定的,所以就变成了一个单纯的技术问题了,数据规模大的话就线段树吧,200太小了,循环都OK

代码:

#include "stdio.h"
#include "string.h"
int pass[201];
int main()
{
int ca,n,i,s,t,j,max,S,T,temp;
scanf("%d",&ca);
while(ca--)
{
max=0;
memset(pass,0,sizeof(pass));
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d%d",&s,&t);
if(s>t)//一定注意哦
{
temp=s;
s=t;
t=temp;
}
s=(s+1)/2;//转化为对应的楼道
t=(t+1)/2;
for(j=s;j<=t;j++)
{
pass[j]++;
if(pass[j]>max) max=pass[j];
}
}
printf("%d\n",max*10);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDU