您的位置:首页 > 大数据 > 人工智能

GCD Again(杭电oj1787)(欧拉函数)

2015-12-17 11:26 411 查看


GCD Again

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2732 Accepted Submission(s): 1157



Problem Description

Do you have spent some time to think and try to solve those unsolved problem after one ACM contest?

No? Oh, you must do this when you want to become a "Big Cattle".

Now you will find that this problem is so familiar:

The greatest common divisor GCD (a, b) of two positive integers a and b, sometimes written (a, b), is the largest divisor common to a and b. For example, (1, 2) =1, (12, 18) =6. (a, b) can be easily found by the Euclidean algorithm. Now I am considering a little
more difficult problem:

Given an integer N, please count the number of the integers M (0<M<N) which satisfies (N,M)>1.

This is a simple version of problem “GCD” which you have done in a contest recently,so I name this problem “GCD Again”.If you cannot solve it still,please take a good think about your method of study.

Good Luck!



Input

Input contains multiple test cases. Each test case contains an integers N (1<N<100000000). A test case containing 0 terminates the input and this test case is not to be processed.



Output

For each integers N you should output the number of integers M in one line, and with one line of output for each line in input.



Sample Input

2
4
0




Sample Output

0
1

这道题就是欧拉函数的运用。
欧拉函数: 对正整数n,欧拉函数是少于或等于n的数中与n互质的数的数目。例如euler(8)=4,因为1,3,5,7均和8互质。
euler函数表达通式:euler(x)=φ(x) =x(1-1/p1)(1-1/p2)(1-1/p3)(1-1/p4)…(1-1/pn),其中p1,p2……pn为x的所有素因数,x是不为0的整数。 (注意:每种质因数只一个。比如 12 = 2*2*3 那么  euler(12)=12*(1-1/2)(1-1/3)=4,特殊情况euler(1)=1。
欧拉函数性质:  1、 φ(mn) = φ(m) φ(n)                           2、若n为奇数,φ(2n) = φ(n)。
欧拉公式的延伸:一个数的所有质因子之和是euler(n)*n/2。
本题是求小于n与n的公因子大于1的个数。即求n-euler(n)-1;
#include<stdio.h>
int euler(int n)
{
	int ans=n;
	for(int i=2;i*i<=n;i++)
	{
		if(n%i==0)
		{
		    ans=ans/i*(i-1);
		    n/=i;
		}
		while(n%i==0)//将重复的因子消去。 
		{
			n/=i;
		}
	}
	if(n>1)   //如果n为质数或者1,那么euler(n)=n-1; 
	    return ans/n*(n-1);
	return ans;
	
}
int main()
{
	int n;
	while(scanf("%d",&n),n)
	{
		printf("%d\n",n-euler(n)-1);
	}
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: