您的位置:首页 > 大数据 > 人工智能

Rails(UVa514)(栈)

2015-12-21 07:13 399 查看



Rails

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only
a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.




The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has

coaches
numbered in increasing order

. The chief for train reorganizations must know whether it is possible to marshal coaches continuing
in the direction B so that their order will be

. Help him and write a program that decides whether it is possible to
get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there
can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.

Input

The input file consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described
above. In each of the next lines of the block there is a permutation of

The
last line of the block contains just 0.
The last block consists of just one line containing 0.

Output

The output file contains the lines corresponding to the lines with permutations in the input file. A line of the output file contains Yes if it
is possible to marshal the coaches in the order required on the corresponding line of the input file. Otherwise it contains No. In addition, there is one empty line after the lines corresponding
to one block of the input file. There is no line in the output file corresponding to the last ``null'' block of the input file.

Sample Input

5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0


Sample Output

Yes
No

Yes


虽然栈的思想很容易理解,但是用栈解起题来,也不是那么容易的。当我在学习算法入门经典,我对书上代码完全不能理解

经过将输入数据模拟代码运行,我终于顿悟。


用A来代表车厢序号,B代表target数组用来表示列车出站的序号顺序。B用来表示已经驶进B的车辆数


代码实现:


#include<stdio.h>
#include<stack>
using namespace std;
const int MAXN=1000+10;
int target[MAXN];

int main()
{
	int n,A,B,ok;
	while(scanf("%d",&n),n)
	{
		stack<int> s;
		while(1){
		scanf("%d",&target[1]);
		if(target[1]==0)  break;
		{
		for(int i=2;i<=n;i++)
		{
		     scanf("%d",&target[i]);
		}
		A=B=ok=1; 
		while(B<=n)  //如果驶向B的车个数等于n,则循环结束。 
		{
			//如果驶向C的车等于驶向B的车的序列号,直接该将车驶进B 
			if(A==target[B]) { A++,B++;} 
			//否则,则判断栈顶的(即在C最上面)车是否等于驶向 B的车 
			else if(!s.empty()&&s.top()==target[B]) {s.pop(),B++;}
			//将车驶进C 
			else if(A<=n) s.push(A++);
			//如果车全部都驶入C,循环还没有结束,意味着所给的target顺序不能实现 
			else
			{
				ok=0;
				break;
			}
		}
		printf("%s\n",ok?"Yes":"No");}}
		printf("\n");
	}
}

在做过 hdoj1022 这道题之后,我发现可以用同样的思路来解决这道题目,思路和代码都比较好理解~


#include<stdio.h>
#include<stack>
using namespace std;
int b[1010];
int main()
{
	int i,n,k,t;
	stack<int> s;
	while(scanf("%d",&n),n)
	{
		while(1){
		while(!s.empty())  //记得栈要清空~在这里WA了好几次。。。 
		{
		   s.pop();
	    }
		k=t=0;
		scanf("%d",&b[0]);
		if(b[0]==0) break;
		for(i=1;i<n;i++)
		    scanf("%d",&b[i]);
		for(i=1;i<=n;i++)
		{
			s.push(i);
			while(!s.empty()&&s.top()==b[k])
			{
				k++;
				s.pop();
			}
		}
		if(s.empty())
			printf("Yes\n");
		else
			printf("No\n");
		}
		printf("\n");
	}
}

[code]


                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: