您的位置:首页 > 大数据 > 人工智能

Train Problem I(杭电1022)(栈的应用)

2015-12-22 00:46 393 查看


Train Problem I

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 27858 Accepted Submission(s): 10565



Problem Description

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one
railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train
B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the
trains can get out in an order O2.









Input

The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample
Input.



Output

The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of
the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.



Sample Input

3 123 321
3 123 312




Sample Output

Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

HintHint 
For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output "No.".




Author

Ignatius.L

使用栈的时候,记得要清空。

第一次做的错误代码:

错误关键:当栈顶元素满足和出栈元素相等的时候,可以一直出栈,所以必须要while语句。。。

#include<stdio.h>
#include<string.h>
#include<stack>
using namespace std;
char a[100];
char b[100];
int vis[100];
int main()
{
	int i,n,k,t,ok;
	stack<char> s;
	while(scanf("%d %s %s",&n,a,b)!=EOF)
	{
		while(!s.empty())
		    s.pop();
		//scanf("%s %s",a,b);
		k=t=ok=0;
		for(i=0;i<n;i++)
		{
			s.push(a[i]);
			vis[t++]=0;
			if(!s.empty()&&s.top()==b[k])
			{
				vis[t++]=1;
				k++;
				s.pop(); 
			}
		}
		while(!s.empty())
		{
			if(s.top()==b[k])
			{
				vis[t++]=1;
				k++;
				s.pop();
			}
			else
			{
				ok=1;
				break;
			}
		}
		if(!ok)
		{
			printf("Yes.\n");
			for(i=0;i<2*n;i++)
			{
				if(!vis[i])
				    printf("in\n");
			    else
			        printf("out\n");
			}
		}
		else
		    printf("No.\n");
		printf("FINISH\n");
	}
}


对上面代码稍作处理就AC了~

#include<stdio.h>
#include<string.h>
#include<stack>
using namespace std;
char a[100];
char b[100];
int vis[100];
int main()
{
	int i,n,k,t;
	stack<char> s;
	while(scanf("%d %s %s",&n,a,b)!=EOF)
	{
		while(!s.empty())//清空栈 
		    s.pop();
		k=t=0;
		for(i=0;i<n;i++)
		{
			s.push(a[i]);//进栈 
			vis[t++]=0;
			while(!s.empty()&&s.top()==b[k])//如果栈顶元素等于目标序号。出栈! 
			{
				vis[t++]=1;
				k++;
				s.pop(); 
			}
		}
		if(s.empty())
		{
			printf("Yes.\n");
			for(i=0;i<2*n;i++)
			{
				if(!vis[i])
				    printf("in\n");
			    else
			        printf("out\n");
			}
		}
		else
		    printf("No.\n");
		printf("FINISH\n");
	}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: