您的位置:首页 > 其它

(hdu step 7.2.1)The Euler function(欧拉函数模板题——求phi[a]到phi[b]的和)

2015-03-19 11:32 441 查看
题目:

The Euler function

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 166 Accepted Submission(s): 96
 
[align=left]Problem Description[/align]The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b) 
[align=left]Input[/align]There are several test cases. Each line has two integers a, b (2<a<b<3000000). 
[align=left]Output[/align]
            Output the result of (a)+ (a+1)+....+ (b) 
[align=left]Sample Input[/align]
3 100
 
[align=left]Sample Output[/align]
3042
 
 
[align=left]Source[/align]2009 Multi-University Training Contest 1 - Host by TJU 
[align=left]Recommend[/align]gaojie 
题目分析:
               欧拉函数,简单题。直接暴力这道题就能过。。。。以下简单介绍一下欧拉函数的一些知识。
1、定义:对于正整数n,φ(n)是小于或等于n的正整数中,与n互质的数的数目。    例如:φ(8)=4,因为1,3,5,7均和8互质。2、性质:1)若p是质数,φ(p)= p-1.   2)若n是质数p的k次幂,φ(n)=(p-1)*p^(k-1)。因为除了p的倍数都与n互质   3)欧拉函数是积性函数,若m,n互质,φ(mn)= φ(m)φ(n).  根据这3条性质我们就可以推出一个整数的欧拉函数的公式。因为一个数总可以写成一些质数的乘积的形式。  E(k)=(p1-1)(p2-1)...(pi-1)*(p1^(a1-1))(p2^(a2-1))...(pi^(ai-1))    = k*(p1-1)(p2-1)...(pi-1)/(p1*p2*...*pi)    = k*(1-1/p1)*(1-1/p2)...(1-1/pk)在程序中利用欧拉函数如下性质,可以快速求出欧拉函数的值(a为N的质因素)  若( N%a ==0&&(N/a)%a ==0)则有:E(N)= E(N/a)*a;  若( N%a ==0&&(N/a)%a !=0)则有:E(N)= E(N/a)*(a-1);

代码如下:
/*
* a1.cpp
*
* Created on: 2015年3月19日
* Author: Administrator
*/

#include <iostream>
#include <cstdio>

using namespace std;

const int maxn = 3000001;

int phi[maxn];

/**
* 初始化欧拉数组.
* phi[8]: 表示从1~8与8互质的元素的个数
*
*/
void prepare(){
int i;
for(i = 1 ; i < maxn ; ++i){
phi[i] = i;
}

int j;
for(i = 2 ; i < maxn ; ++i){
if(phi[i] == i){
for(j = i ; j < maxn ; j += i){
phi[j] = phi[j]/i*(i-1);
}
}
}
}

int main(){
prepare();
int a,b;
while(scanf("%d%d",&a,&b)!=EOF){
long long ans = 0;
int i;
for(i = a ; i <= b ; ++i){//暴力求phi[a]到phi[b]之间的和
ans += phi[i];
}

printf("%lld\n",ans);
}

return 0;
}


以下贴一个TLE了的版本:
TLE的原因很只管,因为每次算phi[i],它都掉了一次phi()。运算量太大。

/*
* POJ_2407.cpp
*
* Created on: 2013年11月19日
* Author: Administrator
*/

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

typedef long long ll;

const int maxn = 1000015;

bool u[maxn];
ll su[maxn];
ll num;

ll gcd(ll a, ll b) {
if (b == 0) {
return a;
}

return gcd(b, a % b);
}

void prepare() {//欧拉筛法产生素数表
ll i, j;
memset(u, true, sizeof(u));

for (i = 2; i <= 1000010; ++i) {
if (u[i]) {
su[++num] = i;
}

for (j = 1; j <= num; ++j) {
if (i * su[j] > 1000010) {
break;
}

u[i * su[j]] = false;

if (i % su[j] == 0) {
break;
}
}
}
}

ll phi(ll x) {//欧拉函数,用于求[1,x)中与x互质的整数的个数
ll ans = 1;
int i, j, k;
for (i = 1; i <= num; ++i) {
if (x % su[i] == 0) {
j = 0;
while (x % su[i] == 0) {
++j;
x /= su[i];
}

for (k = 1; k < j; ++k) {
ans = ans * su[i] % 1000000007ll;
}
ans = ans * (su[i] - 1) % 1000000007ll;
if (x == 1) {
break;
}
}
}

if (x > 1) {
ans = ans * (x - 1) % 1000000007ll;
}

return ans;
}

int main(){

prepare();

long long a;
long long b;
while(scanf("%lld%lld",&a,&b)!=EOF){
long long ans = 0;
long long i;
for(i = a ; i <= b ; ++i){
ans += phi(i);
}

printf("%lld\n",ans);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: