您的位置:首页 > 其它

poj 3660 Cow Contest (Floyd+思维)

2013-07-27 08:53 417 查看
Cow Contest

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6069 Accepted: 3285
Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cowA will always
beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results
of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined

 

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5

Sample Output
2

Source

USACO 2008 January Silver
解题报告:题目的意思是要求输出能够确定比赛排名的牛的个数,刚开始查一下词典“Cow Contest”意思是拓扑,然后我就认为是拓扑排序的题目,但是问题是拓扑好像没办法确定个数,只能确定是否可以确定某种关系。
隔了一天,想一下,如果这头牛能打败的个数x, 加上被打败的个数y ,再加上自身的1 ,如果恰好等于n ,不就可以确定比赛名次了吗!果断ac~~

代码:

#include<cstdio>
#include<cstring>
using namespace std;
int n,m;
int mp[105][105];
void floyd()
{
for(int k=1;k<=n;k++)
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
if(mp[i][k]&&mp[k][j])
mp[i][j]=1;
}

int main()
{
int a,b,cnt1,cnt2,sum;;
while(scanf("%d%d",&n,&m)!=EOF)
{
memset(mp,0,sizeof(mp));
for(int i=1;i<=m;i++)
{
scanf("%d%d",&a,&b);
mp[a][b]=1;
}
floyd();
int x=0,y=0;
sum=0;
for(int i=1;i<=n;i++)
{
cnt1=cnt2=0;
for(int j=1;j<=n;j++)
{
if(mp[i][j]) cnt1++;
if(mp[j][i]) cnt2++;
}
if(cnt1+cnt2+1==n)
sum++;
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  Floyd 思维 图论