您的位置:首页 > 其它

POJ 3660 Cow Contest(Floyd 传递闭包)

2018-01-26 18:32 387 查看
Cow Contest

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions:13814 Accepted: 7681
Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will
always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results
of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined

 

Sample Input
5 5
4 3
4 2
3 2
1 2
2 5


Sample Output
2

如果这头牛跟所有牛之间关系确定,则此牛排名确定

#include<iostream>
#include<cstdio>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
int n,m,i,j,k;scanf("%d%d",&n,&m);
int d[102][102];
memset(d,0,sizeof(d));
for(i=1;i<=m;i++)
{
int x,y;scanf("%d%d",&x,&y);
d[x][y]=1;
}
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
for(k=1;k<=n;k++)
d[j][k]=d[j][k]||(d[j][i]&&d[i][k]);
int sum=0;
for(i=1;i<=n;i++)
{
int ans=0;
for(j=1;j<=n;j++)
if(d[i][j]||d[j][i])ans++;//i beat j or j beat i两种情况
if(ans==n-1) sum++;//跟其他n-1头牛关系确定
}
printf("%d\n",sum);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: