您的位置:首页 > 其它

POJ 3660 Cow Contest [Floyd]

2017-07-09 01:03 363 查看

POJ - 3660 Cow Contest

http://poj.org/problem?id=3660

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined

 

Sample Input

5 5

4 3

4 2

3 2

1 2

2 5

Sample Output

2

这题就是给m个有序对,问这些有序对构成的有向图能确定排名位置的点有几个。

这题用floyd的最短路去做又快又方便,但是我一直用拓扑排序在写所以就一直在WA。补题后看了网上用拓扑排序的题解,原理就是每次拓扑排序以后将未处理的连在同一点边合并,其实也是用了floyd的思想,但是没有直接用最短路思路清晰,而且要多一步并查集去判断是否是一个联通块。

最短路做法:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <string>
#include <vector>
#include <queue>
#include <stack>
#include <set>
#include <map>
#define INF 0x3f3f3f3f
#define lowbit(x) (x&(-x))
using namespace std;
typedef long long ll;

int w[105][105];

int main()
{
int n,m,a,b;
scanf("%d%d",&n,&m);
while(m--)
{
scanf("%d%d",&a,&b);
w[a][b] = 1;
}

for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
for(int k=1;k<=n;k++)
w[j][k] = (w[j][k] > 0 || w[j][i] + w[i][k] == 2);

int res = 0;

for(int i=1;i<=n;i++)
{
int tp = 0;
for(int j=1;j<=n;j++)
if(w[i][j] || w[j][i]) tp++;
if(tp == n-1) res++;
}
printf("%d\n",res);

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: