您的位置:首页 > 其它

POJ 3660 Cow Contest(传递闭包floyed算法)

2015-10-26 17:07 513 查看
Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5

4 3

4 2

3 2

1 2

2 5

Sample Output

2

Source

USACO 2008 January Silver

题目大意:给定N个人,然后知道这N个人的两两对决的情况,前一个为胜者,问M个对决情况中最多能确定几个人的名次.

思路:想到了Floyd算法,可是怎么来关联还是不知所以然,网上查了资料后,才明白用Floy求传递闭包,只要该人的关系和其他人的关系确定,那么他的名次就是确定的。

Code
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;

const int N=110;
int mp

;

int main()
{
int n,m;
while (cin>>n>>m)
{
int i,j,k;
int u,v;
memset(mp,0,sizeof(mp));
for (i=0;i<m;i++)
{
cin>>u>>v;
mp[u][v]=1;
}
for(k=1;k<=n;k++)
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
if(mp[i][k]==1&&mp[k][j]==1) //A和B有关,B和C有关,则Ac有关,不等号的传递性
mp[i][j]=1;
//Floyd();
int ans=0;
for (i=1;i<=n;i++)
{
for (j=1;j<=n;j++)
{
if (j==i) continue;
if (mp[i][j]==0&&mp[j][i]==0) break;
}
if (j>n) ans++;
}
cout<<ans<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: