您的位置:首页 > 其它

Uniform Generator

2020-03-30 07:34 435 查看

Problem Description
Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

seed(x+1) = [seed(x) + STEP] % MOD

where ‘%’ is the modulus operator.

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.

For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.

Input
Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).

Output
For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either “Good Choice” or “Bad Choice” left-justified starting in column 25. The “Good Choice” message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message “Bad Choice”. After each output test set, your program should print exactly one blank line.

Sample Input
3 5
15 20
63923 99999

Sample Output
3 5 Good Choice

15        20    Bad Choice

63923     99999    Good Choice

计算伪随机数是否在0~MOD-1内均匀出现。
seed[x+1]=(seed[x]+STEP)%MOD
假设第k项出现重复,有seed[k]=(seed[0]+k*STEP)%MOD=seed[0],
其中seed[0]=0,seed[k]=k*STEP%MOD=0,
k*STEP=n*MOD,k*STEP肯定是MOD的倍数,
如果在0~MOD-1里均匀分布的话,出现第k项重复,k一定>=MOD,取k=MOD,根据 k*STEP=n*MOD,有MOD*STEP=n*MOD,得到STEP=n,他们互为质数才能是这样。
所以gcd(STEP,MOD)==1,为"Good Choice",否则为"Bad Choice"

C

#include <stdio.h>
#pragma warning(disable:4996)
int gcd(int a,int b)
{
while(1)
{
a%=b;
if(a==0)
return b;
b%=a;
if(b==0)
return a;
}
}
int main(void)
{
int STEP,MOD;
while(scanf("%d %d",&STEP,&MOD)!=EOF)
{
printf("%10d%10d",STEP,MOD);
if(gcd(STEP,MOD)==1)
puts("    Good Choice");   //注意格式,只有4个空格,在第25格输出
else
puts("    Bad Choice");
putchar('\n');
}
return 0;
}
  • 点赞
  • 收藏
  • 分享
  • 文章举报
coffee__a 发布了28 篇原创文章 · 获赞 4 · 访问量 1771 私信 关注
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: