您的位置:首页 > 其它

Sum Problem

2020-03-30 07:34 246 查看

Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + … + n.

Input
The input will consist of a series of integers n, one integer per line.

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input
1
100

Sample Output
1

5050

注意格式,每个输出后要有1个空行,要注意怎么结束循环

C

#include <stdio.h>
#pragma warning(disable:4996)
int main(void)
{
int N,sum,i;
while(scanf("%d",&N)!=EOF)
{
for(sum=0,i=1;i<=N;i++)
sum+=i;
printf("%d\n\n",sum);
}
return 0;
}
  • 点赞
  • 收藏
  • 分享
  • 文章举报
coffee__a 发布了28 篇原创文章 · 获赞 4 · 访问量 1767 私信 关注
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: