您的位置:首页 > 其它

DNA Sorting

2020-03-30 07:33 127 查看

Problem Description
One measure of

unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence
DAABEC’’, this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence
AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence
ZWQM’’ has 6 inversions (it is as unsorted as can be—exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of

sortedness'', from
most sorted’’ to ``least sorted’’. All the strings are of the same length.

Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output
Output the list of input strings, arranged from

most sorted'' to
least sorted’’. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

逆序数列从小到大排序,数据量不大,可以暴力解,也可以用归并排序,我个人还没有会归并排序,这里只放上暴力解的代码。

C

#include <stdio.h>
#pragma warning(disable:4996)
int unsort[100];    //记录逆序数的大小
char ch[100][51];
int main(void)
{
int i,j,k,n,m;
char *pch[100],*temp;    //用指针数组来进行排序,省去直接交换字符串的值
scanf("%d %d",&n,&m);
for(i=0;i<m;i++)
scanf("%s",ch[i]);
for(i=0;i<m;i++)
pch[i]=ch[i];
for(i=0;i<m;i++)
for(j=0;j<n;j++)
for(k=j+1;k<n;k++)
if(ch[i][j]>ch[i][k])
unsort[i]++;
for(i=0;i<m-1;i++)
for(j=0;j<m-1-i;j++)
if(unsort[j]>unsort[j+1])
{
temp=pch[j];
pch[j]=pch[j+1];
pch[j+1]=temp;
unsort[j]^=unsort[j+1]; //冒泡排序要注意交换记录逆序数的数组元素的位置,^=可以不用设置temp就交换两个数的值
unsort[j+1]^=unsort[j];
unsort[j]^=unsort[j+1];
}
for(i=0;i<m;i++)
printf("%s\n",pch[i]);
return 0;
}
  • 点赞
  • 收藏
  • 分享
  • 文章举报
coffee__a 发布了28 篇原创文章 · 获赞 4 · 访问量 1757 私信 关注
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: