您的位置:首页 > 大数据 > 人工智能

Fibonacci Again

2020-03-30 07:34 1011 查看

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)

Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output
Print the word “yes” if 3 divide evenly into F(n). Print the word “no” if not.

Sample Input
0
1
2
3
4
5

Sample Output
no
no
yes
no
no
no

一个斐波那契数列数列,且F[0]=7,F[1]=11,题目问F
能否被3整除,能整除输出yes,否则输出no。有公式(a+b)%p=(a%p+b%p)%p,根据这个公式,就可以算出整个数列上每一项MOD3,如果这一项为0,输出yes,否则输出no。

C

#include <stdio.h>
#pragma warning(disable:4996)
int f[1000000]={1,2};
int main(void)
{
int i=2,n;
while(scanf("%d",&n)!=EOF)
{
for(;i<=n;i++)           //i=2的初始化放在声明那里,可以节省一点时间,数组只会遍历一遍
f[i]=(f[i-1]%3+f[i-2]%3)%3;
if(f[n]==0)
printf("yes\n");
else
printf("no\n");
}
return 0;
}
  • 点赞
  • 收藏
  • 分享
  • 文章举报
coffee__a 发布了28 篇原创文章 · 获赞 4 · 访问量 1762 私信 关注
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: