您的位置:首页 > 移动开发 > IOS开发

A Mathematical Curiosity

2020-03-30 07:34 1101 查看

Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a2+b2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.

Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.

Sample Input
1

10 1
20 3
30 4
0 0

Sample Output
Case 1: 2
Case 2: 4
Case 3: 5

只要读懂题就行,输入会分成几个块,每一个块以0 0结束,输出的时候块与块之间要有一个空行,具体我会在代码中标注

C

#include <stdio.h>
#pragma warning(disable:4996)
int main(void)
{
int N,m,n,count,a,b,Case;
scanf("%d",&N);  //有多少个"块"
while(N--)
{
Case=1;         //每个块中测试的数量是独立的,如在第一个块中有case1,case2等等,但是到了第2个块仍要从1开始
while(scanf("%d %d",&n,&m)&&(n||m))   //n和m同时为0时,一个块结束
{
for(count=0,b=1;b<n;b++)
for(a=1;a<b;a++)
if((a*a+b*b+m)%(a*b)==0)
count++;
printf("Case %d: %d\n",Case++,count);
}
if(N)     //注意每个块之间要有一个空行,最后一个块后面当然就没空行了,所以这里是if(N)
putchar('\n');
}
return 0;
}
  • 点赞 1
  • 收藏
  • 分享
  • 文章举报
coffee__a 发布了28 篇原创文章 · 获赞 4 · 访问量 1768 私信 关注
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: