您的位置:首页 > 大数据 > 人工智能

1021: Fibonacci Again

2012-03-02 14:10 357 查看
Problem Description:

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

Sample Input:

0

1

2

3

4

5

Sample Output:

no

no

yes

no

no

no

//  i    i=0 i=1 i=2 i=3   i=4 i=5 i=6 i=7   i=8 i=9 i=10 1=11
//f(i)%3  1   2   0   2     2   1   0   1     1   2   0    2   (按规律循环出现:2101 1202/ 2101 1202/...... )
//        no  no yes  no    no  no yes  no    no  no  yes
//由上规律可知yes出现位置为2 6 10 14 ......即i%4==2处!!!
#include <iostream>
using namespace std;

int main()
{
int i;
while(cin>>i)
{
if(i%4==2)
cout<<"yes"<<endl;
else
cout<<"no"<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息