您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表三:链表的逆置

2019-07-27 20:51 190 查看

数据结构实验之链表三:链表的逆置
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。
Input
输入多个整数,以-1作为结束标志。
Output
输出逆置后的单链表数据。
Sample Input

12 56 4 6 55 15 33 62 -1

Sample Output

62 33 15 55 6 4 56 12

#include<bits/stdc++.h>

using namespace std;

struct node
{
node *next;
int data;
};
void creat(node *l)
{
node *p, *t;
t = l;
int x;
while(cin>>x && x != -1)
{
p = (node *)malloc(sizeof(node));
p->data = x;
t->next = p;
p->next = NULL;
t = p;
}
}
void mergelist(node *l)
{
node *p, *q;
p = l->next;
l->next = NULL;
q = p->next;
while§
{
p->next = l->next;
l->next = p;
p = q;
if(q)
{
q = q->next;
}
}
}
void print(node *l)
{
node *p;
p = l->next;
while§
{
if(p->next == NULL)
{
cout<data;
}
else
cout<data<<" ";
p = p->next;
}
}
int main()
{
node *l;
l = (node *)malloc(sizeof(node ));
creat(l);
mergelist(l);
print(l);
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: