您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表三:链表的逆置

2017-03-19 21:17 309 查看


数据结构实验之链表三:链表的逆置

Time Limit: 1000MS
Memory Limit: 65536KB
Submit

Statistic

Problem Description

输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。

Input

输入多个整数,以-1作为结束标志。

Output

输出逆置后的单链表数据。

Example Input

12 56 4 6 55 15 33 62 -1


Example Output

62 33 15 55 6 4 56 12


Hint

不得使用数组。

Author

#include <stdio.h>

#include <stdlib.h>

struct node

{

    int data;

    struct  node * next;

};

void re(struct node * head,int n)

{

    struct node *p,*tail;

    tail=head;

    while(tail->next!=NULL)///为了符合顺序建链表

    {

        tail=tail->next;

    }

    p=(struct node *)malloc(sizeof(struct node));

    p->data=n;

    p->next=NULL;

    tail->next=p;

    tail=p;

}

struct node *ar(struct node * head)

{

    struct node *p,*q;

    p=head->next;

    head->next=NULL;

    q=p->next;

    while(p!=NULL)///换最后一个

    {

        p->next=head->next;///逆序插入

        head->next=p;

        p=q;

        if(q!=NULL)

            q=q->next;

    }

    return head;

}

int main()

{

    struct node * head,*p;

    int n;

    head=(struct node *)malloc(sizeof(struct node));

    head->next=NULL;

    while(scanf("%d",&n)!=EOF&&n!=-1)

        re(head,n);

    head=ar(head);

    p=head->next;//从头开始取值;

    while(p->next!=NULL)

    {

        printf("%d ",p->data);

        p=p->next;

    }

    printf("%d\n",p->data);

    return 0;

}

///解决一直输入的情况

/**struct node * creat(struct node * head)

{

    struct node * p,*tail;

    head=(struct node * )malloc(sizeof(struct node ));

    head->next=NULL;

    tail=head;

     while(1)

    {

        p=(struct node * )malloc(sizeof(struct node ));

        p->next=NULL;

        scanf("%d",&p->data);

        if(p->data==-1)

            break;

         tail->next=p;

         tail=p;

    }

    return head;

};*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: