您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表三:链表的逆置

2016-09-02 21:41 435 查看


Problem Description

输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。


Input

输入多个整数,以-1作为结束标志。


Output

输出逆置后的单链表数据。


Example Input

12 56 4 6 55 15 33 62 -1



Example Output

<
4000
span style="font-size:14px;">62 33 15 55 6 4 56 12

#include <stdio.h>

#include <stdlib.h>

struct node

{

    int data;

    struct node *next;

}*head,*p;

int main()

{

  int i,j=0;

  head=(struct node *)malloc(sizeof(struct node));

  head->next=NULL;

  while(j!=-1)

  {

      p=(struct node *)malloc(sizeof(struct node));

      p->next=NULL;

      scanf("%d",&p->data);

      if(p->data==-1)

        break;

      p->next=head->next;

      head->next=p;

  }

  p=head->next;

  while(p!=NULL)

  {

      if(p->next!=NULL)

        printf("%d ",p->data);

      else

        printf("%d\n",p->data);

      p=p->next;

  }

    return 0;

}

#include <stdio.h>

#include <stdlib.h>

struct node

{

    int data;

    struct node *next;

}*p,*q,*head,*tail;

void print(struct node *head)

{  // struct node *p;

    p=head->next;

    while(p!=NULL)

    {

        if(p->next!=NULL)

            printf("%d ",p->data);

        else

            printf("%d\n",p->data);

        p=p->next;

    }

}

struct node *create()

{

  //  struct node *tail,*head,*p;

    int d;

    head=(struct node *)malloc(sizeof(struct node));

    head->next=NULL;

    tail=head;

   while(~scanf("%d",&d)&&(d!=-1))

    {

        p=(struct node *)malloc(sizeof(struct node));

        p->next=NULL;

       p->data=d;

        tail->next=p;

        tail=p;

    }

    return head;

}

void reverse(struct node *head)

{

    //struct node *p,*q;

    p=head->next;

    head->next=NULL;

    q=p->next;

    while(p!=NULL)

    {

        p->next=head->next;

        head->next=p;

        p=q;

        if(q) q=q->next;

    }

}

int main()

{

   struct node *h;

   h=create();

   reverse(h);

   print(h);

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: