您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表三:链表的逆置

2017-01-13 22:31 148 查看

Problem Description

输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。

Input

输入多个整数,以-1作为结束标志。

Output

输出逆置后的单链表数据。

Example Input

12 56 4 6 55 15 33 62 -1


Example Output

62 33 15 55 6 4 56 12


Hint

不得使用数组。 

#include<stdio.h>

#include<stdlib.h>

struct node

{

    int data;

    struct node *next;

};

int main()

{

    struct node *head,*p,*q,*tail,*r;

    head=(struct node*)malloc(sizeof(struct node));

    head->next=NULL;

    q=head;

    while(1)

    {

        p=(struct node*)malloc(sizeof(struct node));             //顺序建表

        scanf("%d",&p->data);

        if(p->data==-1) break;

        p->next=NULL;

        q->next=p;

        q=p;

    }

    p=head->next;                                               //逆置过程

    head->next=NULL;                                            //切记此行,千万不能忘记

    tail=p->next;

    while(p!=NULL)

    {

        p->next=head->next;

        head->next=p;

        p=tail;

        if(tail!=NULL)

            tail=tail->next;

    }

    r=head->next;

    while(r!=NULL)

    {

        if(r->next==NULL)

            printf("%d\n",r->data);

        else

            printf("%d ",r->data);

        r=r->next;

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: