您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表七:单链表中重复元素的删除

2019-07-28 10:27 127 查看

数据结构实验之链表七:单链表中重复元素的删除
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description

按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。
Input

第一行输入元素个数 n (1 <= n <= 15);
第二行输入 n 个整数,保证在 int 范围内。
Output

第一行输出初始链表元素个数;
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。
Sample Input

10
21 30 14 55 32 63 11 30 55 30

Sample Output

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21

#include<bits/stdc++.h>

using namespace std;
struct node
{
node *next;
int data;
};
void creat(node *l, int n)
{
node *p, *t;
t = l;
for(int i = 0; i < n; i++)
{
p = (node *)malloc(sizeof(node));
cin>>p->data;
t->next = p;
p->next = NULL;
t = p;
}
}
void display(node *l)
{
node *p, *q;
p = l->next;
l->next = NULL;
q = p->next;
while§
{
p->next = l->next;
l->next = p;
p = q;
if(q)
{
q = q->next;
}
}
}
int length(node *l)
{
node *p;
p = l->next;
int s = 0;
while§
{
s++;
p = p->next;
}
return s;
}
void deletelist(node *l)
{
node *p, *q, *t;
t = l;
p = l->next;
while§
{
q = l->next;
while(q != p)
{
if(p->data == q->data)
{
t->next = p->next;
p = t;///t在p之后,让p = t;为了保留t的位置
break;///退出while循环,执行t = p;
}
q = q->next;
}
t = p;///和上面对应///如果pq是同一个数,则tp移一位
p = p->next;
}
}

void print(node *l)
{
node *p;
p = l->next;
while§
{
if(p->next == NULL)
cout<data<<endl;
else
cout<data<<" ";
p = p->next;
}
}
int main()
{
node *l;
int n;
l = (node *)malloc(sizeof(node));
l->next = NULL;
cin>>n;
creat(l, n);
display(l);
cout<<length(l)<<endl;
print(l);
deletelist(l);
cout<<length(l)<<endl;
print(l);
return 0;
}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: