您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表三:链表的逆置

2016-09-21 15:31 253 查看


数据结构实验之链表三:链表的逆置

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic


Problem Description

输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。


Input

输入多个整数,以-1作为结束标志。


Output

输出逆置后的单链表数据。


Example Input

12 56 4 6 55 15 33 62 -1



Example Output

62 33 15 55 6 4 56 12



#include <iostream>
#include <stdlib.h>
using namespace std;
typedef struct node
{
int data;
struct node *next;
}sq;
void func(sq *head)
{
sq *tail,*p;
tail=head->next;
head->next=NULL;
p=tail->next;
while(tail)
{
tail->next=head->next;
head->next=tail;
tail=p;
if(p)
p=p->next;
}
}
void pri(sq *head)
{
sq *p;
p=head->next;
while(p)
{
cout<<p->data;
p=p->next;
if(p)
cout<<" ";
else
cout<<endl;
}
}
int main()
{
sq *head,*tail,*p;
head=(sq *)malloc(sizeof(sq));
tail=head;
p=(sq *)malloc(sizeof(sq));
while(cin>>p->data)
{
if(p->data==-1)
{
tail->next=NULL;
break;
}
else
{
tail->next=p;
tail=p;
p=(sq *)malloc(sizeof(sq));
}
}
func(head);
pri(head);
return 0;
}
感觉比较巧妙的一道题。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: