您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表三:链表的逆置

2016-02-11 08:26 561 查看


数据结构实验之链表三:链表的逆置



Time Limit: 1000MS Memory limit: 65536K


题目描述

输入多个整数,以-1作为结束标志,顺序建立一个带头结点的单链表,之后对该单链表的数据进行逆置,并输出逆置后的单链表数据。


输入

输入多个整数,以-1作为结束标志。


输出

输出逆置后的单链表数据。


示例输入

12 56 4 6 55 15 33 62 -1



示例输出

62 33 15 55 6 4 56 12



提示

不得使用数组。


来源


示例程序

#include<bits/stdc++.h>
using namespace std;
typedef struct node
{
int data;
struct node *next;
}LNode,*LinkList;
LinkList CreatList()
{
LNode *tail,*head,*p;
int a;
head=new LNode;
head->next=NULL;
tail=head;
while(cin>>a&&a!=-1)
{
p=new LNode;
p->data=a;
p->next=NULL;
tail->next=p;
tail=p;
}
return head;
}
LinkList InverseList(LinkList head)
{
LNode *p,*q;
p=head->next;
head->next=NULL;
q=p->next;
while(p!=NULL)
{
p->next=head->next;
head->next=p;
p=q;
if(q!=NULL)
{
q=q->next;
}
}
return head;
}
int main()
{
LinkList head;
LNode *p;
head=CreatList();
head=InverseList(head);
p=head->next;
while(p)
{
p->next==NULL?cout<<p->data<<endl:cout<<p->data<<" ";
p=p->next;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: