您的位置:首页 > 其它

PAT (Advanced Level) Practise 1006. Sign In and Sign Out (25)

2017-12-14 16:37 603 查看
1006. Sign In and Sign Out (25)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked
the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:
ID_number Sign_in_time Sign_out_time


where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in tim
d6f2
e must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.
Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:
SC3021234 CS301133

题解:

这题可以算是一道简单的排序题,用stl中的sort排序,最后输出相应的id号即可。

代码:

#include <cstdio>
#include <algorithm>
using namespace std;

const int maxn=1005;
struct Student{
char id[20];
int h1,m1,s1;
int h2,m2,s2;
}stu[maxn];

bool cmp1(Student a,Student b){
if(a.h1!=b.h1) return a.h1<b.h1;
else if(a.m1!=b.m1) return a.m1<b.m1;
else return a.s1<b.s1;
}

bool cmp2(Student a,Student b){
if(a.h2!=b.h2) return a.h2>b.h2;
else if(a.m2!=b.m2) return a.m2>b.m2;
else return a.s2<b.s2;
}

int main(){
int m;
scanf("%d",&m);
for(int i=0;i<m;i++) scanf("%s %d:%d:%d %d:%d:%d",stu[i].id,&stu[i].h1,&stu[i].m1,&stu[i].s1,&stu[i].h2,&stu[i].m2,&stu[i].s2);
sort(stu,stu+m,cmp1);
printf("%s ",stu[0].id);
sort(stu,stu+m,cmp2);
printf("%s",stu[0].id);
return 0;
}
效率较高的方法:


#include <cstdio>
#include <algorithm>
using namespace std;

const int maxn=1005;
struct Student{
char id[20];
int h,m,s;
}temp,ans1,ans2;

bool great(Student a,Student b){
if(a.h!=b.h) return a.h>b.h;
else if(a.m!=b.m) return a.m>b.m;
else return a.s>b.s;
}

int main(){
int m;
scanf("%d",&m);
ans1.h=24,ans1.m=60,ans1.s=60;
ans2.h=0,ans2.m=0,ans2.s=0;
for(int i=0;i<m;i++){
scanf("%s %d:%d:%d",temp.id,&temp.h,&temp.m,&temp.s);
if(great(temp,ans1)==false) ans1=temp;
scanf("%d:%d:%d",&temp.h,&temp.m,&temp.s);
if(great(temp,ans2)==true) ans2=temp;
}
printf("%s %s\n",ans1.id,ans2.id);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  排序 模拟 PAT甲级 PAT