您的位置:首页 > 其它

PAT (Advanced Level) Practise - 1006. Sign In and Sign Out (25)

2017-11-04 22:42 543 查看


1006. Sign In and Sign Out (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked
the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:
ID_number Sign_in_time Sign_out_time


where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.
Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:
SC3021234 CS301133


输出最早时间和最晚的名字。

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <map>
using namespace std;
#define LL long long
const int maxn = 111;
const int inf = 0x3f3f3f3f;
int mp[maxn][maxn];
int flag[maxn];
int cnt=0;
struct node
{
string name;
int hh1,hh2,mm1,mm2,ss1,ss2;
}a[maxn];
bool cmd1(node a,node b)
{
if(a.hh1!=b.hh1){
return a.hh1<b.hh1;
}else{
if(a.mm1!=b.mm1){
return a.mm1<b.mm1;
}else{
return a.ss1<b.ss1;
}
}
}
bool cmd2(node a,node b)
{
if(a.hh2!=b.hh2){
return a.hh2<b.hh2;
}else{
if(a.mm2!=b.mm2){
return a.mm2<b.mm2;
}else{
return a.ss2<b.ss2;
}
}
}
int main()
{
int n;
scanf("%d",&n);
for(int i=1;i<=n;i++){
cin>>a[i].name;
scanf("%d:%d:%d %d:%d:%d",&a[i].hh1,&a[i].mm1,&a[i].ss1,&a[i].hh2,&a[i].mm2,&a[i].ss2);
}
sort(a+1,a+1+n,cmd1);
cout<<a[1].name;
sort(a+1,a+1+n,cmd2);
cout<<" "<<a
.name;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: