您的位置:首页 > 其它

PAT (Advanced Level) Practise 1009. Product of Polynomials (25)

2017-12-16 16:32 387 查看
1009. Product of Polynomials (25)

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where
K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output
3 3 3.6 2 6.0 1 1.6

题解:

典型的多项式乘法题目,代码如下。

代码:

#include <cstdio>
const int maxn=1005;
struct Poly{
int exp;
double cof;
}poly[maxn];

double ans[2*maxn];

int main(){
int n,m;
scanf("%d",&n);
for(int i=0;i<n;i++) scanf("%d%lf",&poly[i].exp,&poly[i].cof);
scanf("%d",&m);
for(int i=0;i<m;i++){
int exp;
double cof;
scanf("%d%lf",&exp,&cof);
for(int j=0;j<n;j++) ans[exp+poly[j].exp]+=cof*poly[j].cof;
}
int cnt=0;
for(int i=0;i<=2000;i++){
if(ans[i]) cnt++;
}
printf("%d",cnt);
for(int i=2000;i>=0;i--){
if(ans[i]) printf(" %d %.1f",i,ans[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数学 PAT甲级 PAT