您的位置:首页 > 其它

PAT (Advanced Level) Practise 1010. Radix (25)

2017-12-17 09:57 453 查看
1010. Radix (25)

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is "yes", if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:

N1 N2 tag radix

Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number "radix" is the radix of N1 if "tag"
is 1, or of N2 if "tag" is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print "Impossible". If the solution is not unique, output the smallest possible radix.
Sample Input 1:
6 110 1 10

Sample Output 1:
2

Sample Input 2:
1 ab 1 2

Sample Output 2:
Impossible

代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

typedef long long ll;
ll Map[256];

void init(){
for(char c='0';c<='9';c++) Map[c]=c-'0';
for(char c='a';c<='z';c++) Map[c]=c-'a'+10;
}

ll convertNum10(char a[],int radix){
ll ans=0;
int len=strlen(a);
for(int i=0;i<len;i++) ans=ans*radix+Map[a[i]];
return ans;
}

int cmp(char n2[],ll radix,ll t){
int len=strlen(n2);
ll num=convertNum10(n2,radix);
if(num<0) return 1;
if(num>t) return 1;
else if(num<t) return -1;
else return 0;
}

ll binarySearch(char n2[],ll left,ll right,ll t){
ll mid;
while(left<=right){
mid=(left+right)/2;
int flag=cmp(n2,mid,t);
if(flag==0) return mid;
else if(flag==-1) left=mid+1;
else right=mid-1;
}
return -1;
}

int findLargestDigit(char n2[]){
int ans=-1,len=strlen(n2);
for(int i=0;i<len;i++){
if(Map[n2[i]]>ans) ans=Map[n2[i]];
}
return ans+1;
}

char n1[20],n2[20];
int tag,radix;

int main(){
init();
scanf("%s%s%d%d",n1,n2,&tag,&radix);
if(tag==2) swap(n1,n2);
ll t=convertNum10(n1,radix);
ll low=findLargestDigit(n2);
ll high=max(low,t)+1;
ll ans=binarySearch(n2,low,high,t);
if(ans==-1) printf("Impossible\n");
else printf("%lld\n",ans);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息