您的位置:首页 > 其它

浙大 PAT Advanced level 1006. Sign In and Sign Out

2016-04-19 08:45 344 查看
At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked
the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3

CS301111 15:30:28 17:00:10

SC3021234 08:00:00 11:25:25

CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

非常简单的题目,熟悉标准库的情况下,使用string类(#include <string>)可以大幅简化过程。

第一次提交的代码

#include <iostream>
#include <string.h>
using namespace std;

typedef struct record
{
char ID_number[16];
char Sign_in_time[9];
char Sign_out_time[9];
}record;

void cin_record(record &temp)
{
char buf[40];
int length = 1;

cin.getline(buf, 40);
while(' ' != buf[length])
{
++length;
}
memcpy(temp.ID_number, buf, length);
temp.ID_number[length] = '\0';
memcpy(temp.Sign_in_time, buf+length+1, 8);
temp.Sign_in_time[8] =  '\0';
memcpy(temp.Sign_out_time, buf+length+10, 8);
temp.Sign_out_time[8] = '\0';
}

int main()
{
record temp;
record first_in;
record last_out;
int M;

cin >> M;
cin.get();							// 读入紧接M后的回车
cin_record(temp);
first_in = temp;
last_out = temp;
--M;
while (M--)
{
cin_record(temp);
if (strcmp(temp.Sign_in_time, first_in.Sign_in_time) < 0)
{
first_in = temp;
}
if (strcmp(temp.Sign_out_time, last_out.Sign_out_time) > 0)
{
last_out = temp;
}
}

cout << first_in.ID_number << ' ' << last_out.ID_number << endl;

// system("pause");
return 0;
}


优化的代码

#include <iostream>
#include <string>
using namespace std;

int main()
{
string first_sign_in_id, last_sign_out_id;
string first_sign_in_time = "23:59:59", last_sign_out_time = "00:00:00";
string id_number, sign_in_time, sign_out_time;
int M;
cin >> M;
while (M--)
{
cin >> id_number >> sign_in_time >> sign_out_time;
if (sign_in_time < first_sign_in_time)
{
first_sign_in_time = sign_in_time;
first_sign_in_id = id_number;
}
if (sign_out_time > last_sign_out_time)
{
last_sign_out_time = sign_out_time;
last_sign_out_id = id_number;
}
}
cout << first_sign_in_id << ' ' << last_sign_out_id << endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: