您的位置:首页 > 其它

【PAT (Advanced Level)】1006. Sign In and Sign Out (25)

2014-08-05 16:13 429 查看


1006. Sign In and Sign Out (25)

时间限制

400 ms

内存限制

32000 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked
the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:
ID_number Sign_in_time Sign_out_time


where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.
Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:
SC3021234 CS301133


简单题,输入时间,比较一下排序就可以了;

代码:
/************************************
This is a test program for anything
Enjoy IT!
************************************/

#include <iostream>
#include <iomanip>
#include <algorithm>
#include <vector>
#include <list>
#include <set>
#include <fstream>
#include <string>
#include <cmath>
using namespace std;

struct Student
{
string ID;
string sign_in;
string sign_out;
Student(string id, string in, string out)
: ID(id), sign_in(in), sign_out(out){}
};

bool inComp(const Student &l, const Student &r)
{
for (int i = 0; i < 9; i++)
{
if (l.sign_in[i] == r.sign_in[i]) continue;
return l.sign_in[i] < r.sign_in[i];
}
}

bool outComp(const Student &l, const Student &r)
{
for (int i = 0; i < 9; i++)
{
if (l.sign_out[i] == r.sign_out[i]) continue;
return l.sign_out[i] > r.sign_out[i];
}
}

int main()
{
ifstream cin;
cin.open("in.txt");
ofstream cout;
cout.open("out.txt");
//////////////////////////////////////////////////////////////////////////
// TO DO Whatever You WANT!
int n;
while (cin >> n)
{
vector<Student> vS;
for (int i = 0; i < n; i++)
{
string id, in, out;
cin >> id >> in >> out;
Student st(id, in, out);
vS.push_back(st);
}
sort(vS.begin(), vS.end(), inComp);
cout << vS.front().ID << " ";
sort(vS.begin(), vS.end(), outComp);
cout << vS.front().ID << endl;
}
//////////////////////////////////////////////////////////////////////////
// system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT