您的位置:首页 > 其它

LightOJ - 1341- Aladdin and the Flying Carpet

2017-11-09 12:21 393 查看
It’s said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin’s uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.

Input

Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.

Output

For each case, print the case number and the number of possible carpets.

Sample Input

2

10 2

12 2

Sample Output

Case 1: 1

Case 2: 2

#include <cstdio>
#include <cstring>
typedef long long ll;
const int maxn = 1000050;
int pri[maxn];
int vis[maxn];
ll cnt;
void prime()
{
cnt = 0;
memset(vis,false,sizeof(vis));
for (int i = 2; i < maxn; ++i)
{
if (!vis[i])
{
pri[cnt++] =  i;
for (int j = i; j < maxn; j+=i)
{
vis[j] = true;
}
}
}
}
ll fin(ll n)
{
ll ans = 1;
for(int a = 0; a < cnt&&pri[a]<=n; a ++)
{
if(n%pri[a]==0)
{
ll k = 0;
while(n%pri[a]==0)
{
k ++;
n/=pri[a];
}
ans*=(k+1);
}
}
if(n>1) ans*=2;
return ans;
}
int main()
{
int t,kase = 1;
ll a,b;
prime();
scanf("%d",&t);
while(t --)
{
scanf("%lld%lld",&a,&b);
if(a/b<b)
{
printf("Case %d: %lld\n",kase++,0);
continue;
}
ll ans = fin(a);
ans/=2;
for(int i = 1; i < b; i ++)
{
if(a%i==0)
ans--;
}
printf("Case %d: %lld\n",kase++,ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: