您的位置:首页 > 其它

PAT_A 1124. Raffle for Weibo Followers (20)

2017-03-07 11:20 519 查看

1124. Raffle for Weibo Followers (20)

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo – that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (<= 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John’s post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print “Keep going…” instead.

Sample Input 1:

9 3 2

Imgonnawin!

PickMe

PickMeMeMeee

LookHere

Imgonnawin!

TryAgainAgain

TryAgainAgain

Imgonnawin!

TryAgainAgain

Sample Output 1:

PickMe

Imgonnawin!

TryAgainAgain

Sample Input 2:

2 3 5

Imgonnawin!

PickMe

Sample Output 2:

Keep going…

分析:这题很简单!一次AC!可是考试的时候,不熟悉考试环境,结果做了整整半小时!

code:

#include<iostream>
#include<vector>
using namespace std;
int M;
int N;
int S;

string tmp_s;
vector<string>que;
int main()
{
cin>>M>>N>>S;
int tmp_a=S-1;
bool isNo=true;
for(int i=0;i<M;i++)
{
cin>>tmp_s;
for(int j=0;j<que.size();j++)
{
if(tmp_s==que.at(j))
{
tmp_a++;
}
}
if(i==tmp_a)
{
isNo=false;
cout<<tmp_s<<endl;
que.push_back(tmp_s);
tmp_a+=N;
}
}
if(isNo==true)
cout<<"Keep going..."<<endl;

return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  字符串