您的位置:首页 > 其它

PAT (Advanced Level) 1124. Raffle for Weibo Followers (20) 解题报告

2017-03-05 13:16 423 查看


1124. Raffle for Weibo Followers (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo -- that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the
list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (<= 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines
follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John's post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print "Keep going..." instead.
Sample Input 1:
9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain

Sample Output 1:
PickMe
Imgonnawin!
TryAgainAgain

Sample Input 2:
2 3 5
Imgonnawin!
PickMe

Sample Output 2:
Keep going...


代码:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <map>
#include <queue>
#include <string>
#include <vector>
using namespace std;

int main()
{
char name[1010][50];
int m, n, s, f = 0;
map<string, int> M;
scanf("%d%d%d", &m, &n, &s);
for(int i = 1; i <= m; i++)
scanf("%s", name[i]);
for(int i = s; i <= m; i += n)
{
if(!M[name[i]])
{
M[name[i]] = 1;
printf("%s\n", name[i]);
f = 1;
}
else
{
while(i < m)
{
i++;
if(!M[name[i]])
{
M[name[i]] = 1;
printf("%s\n", name[i]);
f = 1;
break;
}
}
}
}
if(!f) printf("Keep going...\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat