您的位置:首页 > 其它

pat 甲1124. Raffle for Weibo Followers (水题)

2017-03-07 18:34 357 查看


1124. Raffle for Weibo Followers (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo -- that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the
list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (<= 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines
follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John's post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print "Keep going..." instead.
Sample Input 1:
9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain

Sample Output 1:
PickMe
Imgonnawin!
TryAgainAgain

Sample Input 2:
2 3 5
Imgonnawin!
PickMe

Sample Output 2:
Keep going...

tips:水题,心态最重要

#include<iostream>
#include<vector>
#include<string>
#include<set>
using namespace std;

vector<string>v;
set<string>st;
int n,m,s;
int main()
{
cin>>n>>m>>s;

for(int i=0;i<n;i++)
{
string ss;cin>>ss;
v.push_back(ss);
}
if(s-1>=v.size()){
cout<<"Keep going..."<<endl;return 0;}

for(int i=s-1;i<v.size();i+=m)
{
string ss=v[i];
if(!st.count(ss))
{
cout<<v[i]<<endl;
st.insert(ss);
}
else
{
while(i+1<v.size()&&st.count(v[++i]));
cout<<v[i]<<endl;
st.insert(v[i]);
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: