您的位置:首页 > 编程语言 > C语言/C++

PAT:1124. Raffle for Weibo Followers (20)

2017-12-07 13:01 447 查看


1124. Raffle for Weibo Followers (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo -- that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the
list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (<= 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines
follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John's post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print "Keep going..." instead.
Sample Input 1:
9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain

Sample Output 1:
PickMe
Imgonnawin!
TryAgainAgain

Sample Input 2:
2 3 5
Imgonnawin!
PickMe

Sample Output 2:
Keep going...

思路:定义一个vector存放被选中的人,将所有follower保存到一个string数组,然后遍历这个数组,如果vector中存在这个人,就跳到下一个人。选中一个人后,改变s为s+n。

#include<bits/stdc++.h>
using namespace std;
vector<string> award;
//map<string,int> mapp;
string fls[1006];
int m,n,s;
int _find(string aim){
for(int i = 0; i < award.size(); i++){
if(aim == award[i])
return 1;
}
return 0;
}

int main(){
cin>>m>>n>>s;

for(int i = 1; i <= m; i++)
cin>>fls[i];
while(s <= m){
//int i = 0;
while(s<= m && _find(fls[s]))s++;
if(s <= m)
award.push_back(fls[s]);
s += n;
}
if(award.size() == 0){
cout<<"Keep going..."<<endl;
return 0;
}
for(int i = 0; i < award.size(); i++)
cout<<award[i]<<endl;
//cout<<mapp.size()<<endl;
}
/*
5 1 1
sss
sss
sss
sss
sss
sss
*/

最后说一下,map竟然可以直接map[key] = value这样用,看了别人的代码涨姿势了~
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息